System Wide Issue
Incident Report for Trakstar Hire
Resolved
We have seen no further issues, and are marking this as resolved!
Posted Jul 27, 2022 - 08:28 PDT
Monitoring
We have repaired the issue and are monitoring the results.
Posted Jul 27, 2022 - 08:11 PDT
Investigating
We are currently investigating a system wide issue. We will update once we know more.
Posted Jul 27, 2022 - 08:00 PDT
This incident affected: Trakstar Hire (Application).