Generic Login Page issue - Use Company Specific Login Page
Incident Report for Trakstar Hire
Resolved
This issue has been resolved. If you have any further issues reach out to hire@trakstar.com
Posted Feb 06, 2024 - 08:43 PST
Monitoring
This issue should be resolved. We are monitoring the results.
Posted Feb 06, 2024 - 08:16 PST
Identified
We have identified an issue with the generic login page for Trakstar Hire.
(https://app.hire.trakstar.com/accounts/start-login)

If you are running in to this issue, replacing "app" in the URL above with your Trakstar Hire company name will solve the problem.

Example:
Instead of - https://app.hire.trakstar.com/accounts/start-login
Use - https://(YOUR COMPANY NAME).hire.trakstar.com/accounts/start-login
For instance: https://mitratech.hire.trakstar.com/accounts/start-login

If you are unsure of your company name, please reach out to us via hire@trakstar.com and we're happy to help!
Posted Feb 06, 2024 - 07:28 PST
This incident affected: Trakstar Hire (Application).