Login Issue
Incident Report for Trakstar Hire
Resolved
This incident has been resolved.
Posted Nov 03, 2022 - 05:38 PDT
Update
This issue is impacting Single Sign-On and Google login. As we continue to work on a fix, you can login using the following link: https://app.hire.trakstar.com/accounts/start-login
Posted Nov 02, 2022 - 08:47 PDT
Identified
We have identified an issue that results in an error when attempting to login to the Trakstar Hire app.

As our team works to resolve this, you can login using the following link: https://app.hire.trakstar.com/accounts/start-login
Posted Nov 02, 2022 - 07:35 PDT
This incident affected: Trakstar Hire (Application).