System - Wide error messages

Incident Report for Trakstar Hire

Resolved

This issue is resolved. If you're still facing issues, we suggest refreshing the page. If that doesn't solve it, feel free to reach out to us at hire@trakstar.com!
Posted Jul 31, 2023 - 06:13 PDT

Monitoring

We have deployed a fix, and are monitoring the results. If you're still facing issues, we suggest refreshing the page. If that doesn't solve it, feel free to reach out to us at hire@trakstar.com!
Posted Jul 31, 2023 - 05:43 PDT

Identified

We have identified an issue causing a system-wide error popup. We're currently putting a fix in place.
Posted Jul 31, 2023 - 04:46 PDT
This incident affected: Trakstar Hire (Application).