Slow Loading
Incident Report for Trakstar Hire
Resolved
This incident has been resolved.
Posted Dec 22, 2023 - 05:52 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2023 - 05:48 PST
Identified
We have been working on a variety of fixes to increase the application speed. While we continue working on this you may see slow load times throughout the application. As we have a fix in place, we'll update here!
Posted Dec 18, 2023 - 12:07 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 18, 2023 - 10:13 PST
Identified
We have identified a potential cause and are working on a fix.
Posted Dec 18, 2023 - 10:07 PST
Update
We are continuing to investigate this issue.
Posted Dec 18, 2023 - 09:33 PST
Investigating
We are currently investigating an issue resulting in widespread slow loading of Trakstar Hire.
Posted Dec 18, 2023 - 08:05 PST
This incident affected: Trakstar Hire (Application).