System Wide Issue

Incident Report for Trakstar Hire

Resolved

We are seeing no further issues. Should you see any further issues, please reach out to support via hire@trakstar.com
Posted Jun 06, 2022 - 12:20 PDT

Monitoring

We have put a fix in place and are awaiting the results.
Posted Jun 06, 2022 - 12:03 PDT

Investigating

We are currently investigating a system wide issue.
Posted Jun 06, 2022 - 11:27 PDT
This incident affected: Trakstar Hire (Application).