Trakstar Hire Outage

Incident Report for Trakstar Hire

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 14:44 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 06, 2026 - 13:40 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 06, 2026 - 09:40 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 06, 2026 - 08:21 EST

Monitoring

Trakstar Hire is back up and running. The 504 errors have stopped, and the team is keeping an eye on things to make sure it stays stable.
Posted Feb 06, 2026 - 07:53 EST

Investigating

We’re seeing reports that Trakstar Hire is down and displaying 504 errors. Our team is on it and working to get things back up as quickly as possible.
Posted Feb 06, 2026 - 06:54 EST
This incident affected: Trakstar Hire (Application), API (api.recruiterbox.com), Server Infrastructure, and Insights Dashboard.