Issue with sending Offer Letters, the Job Widget, and sending Excel reports

Incident Report for Trakstar Hire

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 17:34 PST

Investigating

We’re actively investigating an issue affecting Offer Letters, Excel report delivery, and the Jobs Widget. Our team is already on it and working to resolve the problem as quickly as possible
Posted Feb 04, 2025 - 09:26 PST
This incident affected: Trakstar Hire (Application).