Trakstar Hire delays 06/21/24 7:12pm EST
Incident Report for Trakstar Hire
Resolved
This incident has been resolved.
Posted Jun 21, 2024 - 17:24 PDT
Investigating
We are seeing delays in email notifications (both to internal users and to candidates), as well as candidate application processing. The team is investigating and working quickly to resolve the issue.
Posted Jun 21, 2024 - 16:12 PDT
This incident affected: Trakstar Hire (Application), API (api.recruiterbox.com), and Server Infrastructure.