System Outage

Incident Report for Trakstar Hire

Resolved

This issue has been resolved. If you're still facing difficulties, you can always reach us at hire@trakstar.com
Posted 2 years ago. May 09, 2023 - 19:31 PDT

Monitoring

We are monitoring a fix that has been put in place.
Posted 2 years ago. May 09, 2023 - 18:58 PDT

Investigating

We are currently investigating a system outage. We will update as soon as we know more.
Posted 2 years ago. May 09, 2023 - 18:47 PDT
This incident affected: Trakstar Hire (Application).