Slow Load Times and Errors

Incident Report for Trakstar Hire

Resolved

This incident has been resolved.
Posted Feb 13, 2024 - 08:51 PST

Monitoring

We have put in a fix and are seeing stability.
Posted Feb 13, 2024 - 08:03 PST

Identified

We have identified an issue causing slow load times, and some error messages. Our team is working on a fix.
Posted Feb 13, 2024 - 07:22 PST
This incident affected: Trakstar Hire (Application).