System Wide Issue
Incident Report for Trakstar Hire
Resolved
This incident has been resolved.
Posted May 21, 2023 - 09:28 PDT
Update
We are still working on identifying a root cause, and could experience more instability as we do. We'll continue to update here as we know more.
Posted May 20, 2023 - 14:27 PDT
Investigating
We are currently investigating a system wide issue resulting in instability within the app. Our engineering team is actively working to resolve this issue, and we will update once we know more.
Posted May 20, 2023 - 12:03 PDT
This incident affected: Trakstar Hire (Application).