Investigating System Issue
Incident Report for Trakstar Hire
Resolved
The issue is resolved!
Posted Dec 21, 2022 - 14:15 PST
Monitoring
We have found a fix (again) and are monitoring the results.
Posted Dec 21, 2022 - 13:28 PST
Identified
We are investigating further issues.
Posted Dec 21, 2022 - 13:22 PST
Monitoring
We have found a fix and are monitoring the results.
Posted Dec 21, 2022 - 13:19 PST
Investigating
We are currently investigating an issue causing issues with logging in and navigating the system. The team is working on a fix.
Posted Dec 21, 2022 - 12:50 PST
This incident affected: Trakstar Hire (Application).