System Wide Issue
Incident Report for Trakstar Hire
Resolved
The issue has been resolved.
Posted May 31, 2022 - 08:13 PDT
Monitoring
We have applied a fix, and are monitoring the results. Currently everything is back up and running.
Posted May 31, 2022 - 06:12 PDT
Identified
We have identified the issue, and are deploying a fix. We'll update once we know more!
Posted May 31, 2022 - 05:59 PDT
Investigating
We are currently investigating system wide issues. Once we have more information, we will update!
Posted May 31, 2022 - 05:23 PDT
This incident affected: Trakstar Hire (Application).