System Wide Issue

Incident Report for Trakstar Hire

Resolved

This incident has been resolved.
Posted 2 years ago. May 20, 2023 - 10:51 PDT

Monitoring

We have implemented a fix. We are still working on root cause, and could experience more instability as we do. We'll continue to update here as we know more.
Posted 2 years ago. May 20, 2023 - 06:55 PDT

Investigating

We are currently investigating a system wide issue. We will update once we know more.
Posted 2 years ago. May 20, 2023 - 06:44 PDT
This incident affected: Trakstar Hire (Application).